Live Streaming

Full Version: RVC video chat and Adobe Flash Builder 4.5
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
RVC video chat was built with Adobe Flash Builder 4.0 using SDK 3.5. When trying to edit and create a release build with AFB 4.5 (SDK 4.5) you may encounter some errors, most errors not related to AFB/SDK 4.5:

Error: Unknown Flex SDK: "Flex 3.5"
Quote:Description: Unknown Flex SDK: "Flex 3.5"
Severity: Error
On element: 5.6
Location: line -1
Solution: edit /.actionScriptProperties, locate the compiler section:
Code:
<compiler additionalCompilerArguments="-locale en_US -define+=CONFIG::DEBUGGING,false &quot;-define+=CONFIG::RELEASE,CONFIG::DEBUGGING == false&quot;" autoRSLOrdering="false" copyDependentFiles="true" fteInMXComponents="false" generateAccessible="false" htmlExpressInstall="true" htmlGenerate="false" htmlHistoryManagement="true" htmlPlayerVersionCheck="true" includeNetmonSwc="false" outputFolderPath="bin-debug" removeUnusedRSL="true" sourceFolderPath="src" strict="true" targetPlayerVersion="10.0.0" useApolloConfig="false" useDebugRSLSwfs="true" verifyDigests="true" warn="true">
and remove flexSDK="Flex 3.5"

Error: The target Flash Player version 10.0.0.0 specified should be equal or higher than the minimum version 10.2.0.0 required by Flex SDK.
Quote:Description: The target Flash Player version 10.0.0.0 specified should be equal or higher than the minimum version 10.2.0.0 required by Flex SDK.
Severity: Error
On element: 5.6
Location: line -1
Solution: edit /.actionScriptProperties, locate the compiler and change targetPlayerVersion="10.0.0" to targetPlayerVersion="0.0.0"

Error: unable to open '[path]/Documents/Adobe Flash Builder 4.5/5.6/libs'
Quote:Description: unable to open '[path]/Documents/Adobe Flash Builder 4.5/5.6/libs'
Severity: Error
On element: 5.6
Location: line -1
Solution: create /libs folder in the root directory and leave it empty

Error: 1046: Type was not found or was not a compile-time constant: MapEvent.
Quote:Description: 1046: Type was not found or was not a compile-time constant: MapEvent.
Severity: Error
On element: JabberCam.mxml
In folder: 5.6/src
Location: line 558
Solution: this is not an issue with FB, the Google maps library is missing (map_flex_1_20.swc from sdk.zip), read paragraph #8 of the "Importing the flex project" section here: http://www.videosoftware.pro/forum/THREAD-%09-Installing-and-editing-RVC-5-PART2-step-by-step-description

Error: The style '...' is only supported by type 'mx.core.Application' with the theme(s) 'halo'.
Quote:Description: The style '...' is only supported by type 'mx.core.Application' with the theme(s) 'halo'.
Severity: Error
On element: *.mxml
Location: line *
Solution: use the Halo theme. Select one of the mxml files, ex. JabberCam.mxml and set the Editor to "Design" mode. On the right, under "Project theme", set the "Current theme" form "Spark" (or else) to "Halo" (Adobe Themes - Halo (2))

Error: The style 'paddingTop' is excluded by type 'mx.containers.Canvas'.
Quote:Description: The style 'paddingTop' is excluded by type 'mx.containers.Canvas'.
Severity: Error
On element: *.mxml
Location: line *
Solution: remove the paddingTop or paddingTop="0" attributes, where necessary.

Warning: Multiple warnings. Ignore them, multiple arguments are deprecated since 4.0 and some CSS properties are not processed. These warnings will be removed before RVC 6.0.